Thursday, January 05, 2006

Microsoft Natural Ergonomic Keyboard 4000

For a very long time one of the first Microsoft Natural Keyboards has served me dutifully, however when I read about the new 4000 I decided to retire the old one and replace it with its modern successor. I especially appreciate the "sane" layout of the Home, PageUp, PageDn etc. and cursor keys, one of the reasons I did never buy any of the other variants of MS's keyboards, that had them shuffled around for no reason immediately apparent to me.

So I ordered a 4000 from amazon.de for 43€ and was very pleased with its look, when it finally arrived. However reality soon had me back when I found out that the volume control keys did not work at all. The mute key and all of the other special keys worked perfectly, however. So I tried the usual procedure of uninstalling and reinstalling the IntelliType driver software, numerous reboots and unplug/replug cycles. Bottom line: Nothing made the volume keys work. I even began to suspect a hardware malfunction, but several people on the net reported the exact same problem. I tried on Windows 2000 SP4, others on XP and various patchlevels; nothing seemed to help.

For a while I decided to ignore the problem and guess what... Someone else solved it in the meantime. Googling around, looking for some new ideas I stumbled across a forum entry (don't remember the URL) and found the following solution:

rundll32.exe hid.dll,HidservInstaller /install

As it seems sometimes Windows gets confused about some HID settings and running the above command from a CMD shell or via the Start Menu's Run... option fixes the keys. On one machine they started working immediately, on my other computer which I tried with the same keyboard, I had to reboot once.

So thanks again to the unknown person who posted the original solution, you have saved my keyboard from returning to amazon :)

Update: In case this does not work for you, try one of the following tips (I have not had to try those out, but found them on www.codinghorror.com and think I might copy it here if you came here via a search engine):

  • MS Natural Ergonomic Keyboard 4000: Volume Control Keys not working...
    
    Volume control seems to work fine if you start the "HID Input Service".
    If you are not able to start it (happened to me), fire up the registry
    editor and find:
    
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HidServ\Parameters
    
    If there's a string called "ServiceDll" delete it, and create a new one
    (expandable string named "ServiceDll") with this value:
    
    %SystemRoot%\System32\hidserv.dll
    
    Gary
    Gary on December 29, 2005 10:46 PM
  • The post by Gary worked for me too. I had the same issue with the volume buttons...
    
    My problem was I could not start the HID service...
    
    After adding the registry value that Gary mentioned:
    
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HidServ\Parameters
    
    If there's a string called "ServiceDll" delete it, and create a new one
    (expandable string named "ServiceDll") with this value:
    
    %SystemRoot%\System32\hidserv.dll
    
    Then starting the HID service through the control panel, the volume button worked great.
    
    Thanks Gary!
    
    
    Ken on January 5, 2006 12:50 PM 

Be sure to have a look at the site mentioned above, there is lots of discussion going on there about the keyboard.

If all of the above still does not work, maybe this could help (found here):

  • Hi Sharon,
    
    Thanks for the response! Found the below from another MVP over in the
    general group and checked my system. Sure enough two of the three files are
    not on my XP installation. Will try this idea first as it probably can not
    start without the needed files.
    
    > Could not start the Human Interface Device Access service on Local
    > Computer. Error 126: the specified module could not be found
    >
    >  Extract hidserv.dll, mouhid.sys and mouclass.sys from drivers.cab in the
    >  Windows XP CD to "\Windows\System32\" to fix the issue.
    >
    >  1.Insert Windows XP Setup CD.
    >  2.Browse to :\i386\drivers.cab
    >  3.Double click the drivers.cab file. The compressed files in the Cab file
    >  will be listed.
    >  4.Copy the three files to \windows\system32\. Reboot the
    >  computer.
    >
    >  The Human Interface Device Access service will then be started.

2 comments:

Rick Veenstra said...

Thanks for this post. Just received the keyboard a few days ago and I found all the other comments and possibilities except the last one about manually entering the *.dll and the *.sys files.

Because I use the keyboard at work I did not have a windows cd to find the cab file, but thank god for google. After downloading the files and a restart the volume buttons work like a charm now!

Anonymous said...
This comment has been removed by a blog administrator.